1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. GTA Network forum is now in archive mode.

ShittyRP

Discussion in 'Gamemodes' started by Icaro, Feb 15, 2017.

  1. SkyMesA

    SkyMesA New Member

    Messages:
    1
    Likes Received:
    0
    Joined:
    Apr 6, 2017
    Si t'es français ajoute moi steam : http://steamcommunity.com/id/pereneul/
     
  2. Icaro

    Icaro Active Member

    Messages:
    59
    Likes Received:
    36
    Joined:
    Oct 20, 2016
    Si t'as le réparer, svp poster ici comment vous avez le faire. Je vais retourner a mon ordinateur en quelque mois... Maintenant je peu pas vous-aide.

    Try changing the uses of Convert.ToDouble to Double.TryParse, I have a feeling that might work.
     
  3. Haki

    Haki Member

    Messages:
    16
    Likes Received:
    3
    Joined:
    Apr 4, 2017
    Icaro don't bother to translate, we're ok with english ;-)

    I'll try to make it work and post the solution here. Also trying what you said
     
  4. MrMcain

    MrMcain Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    Apr 6, 2017
    I think I fixed but not sure all works in game.
    So I place // before loadShapes() like this //loadShapes(); and //loadVends(); in Interaction.cs. After, //loadHomes(); in Homes.cs and //loadOwnedVehicles(); and //loadVehicles();
    The gamemode start and I can register/login.
     
  5. Icaro

    Icaro Active Member

    Messages:
    59
    Likes Received:
    36
    Joined:
    Oct 20, 2016
    Commenting out those methods will disable a huge chunk of functionality in the gamemode. Put them all in try/catch instead... they should have been in the first place.
     
  6. MrMcain

    MrMcain Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    Apr 6, 2017
    How can I do that ? I'm a beginner in that :=)
     
  7. yurdead

    yurdead New Member

    Messages:
    3
    Likes Received:
    1
    Joined:
    Feb 10, 2017
    Hello @MrMcain :
    Can you drop a link of the gamemode ShittyRpg if it's work for you , Whif the fix plz ,
    Would be great for me !
    thx
    Yurdead
     
  8. MrMcain

    MrMcain Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    Apr 6, 2017
    Hello @yurdead , my fix is not good for playing apparently
     
  9. Haki

    Haki Member

    Messages:
    16
    Likes Received:
    3
    Joined:
    Apr 4, 2017
    I didn't have time to try the fix, but MrMcain's solution disables every feature of the gamemode
     
  10. Keks-danger

    Keks-danger New Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    Apr 10, 2017
  11. thefunixx

    thefunixx New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Apr 12, 2017
    I have the same problem if member have the solution tell me :/
     
  12. ShotGun21

    ShotGun21 Member

    Messages:
    26
    Likes Received:
    0
    Joined:
    Feb 26, 2017
    Cheers, I've corrected the error. It worked without losses in the code.
     
  13. thefunixx

    thefunixx New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Apr 12, 2017
    Okay what is the error ?
     
  14. ShotGun21

    ShotGun21 Member

    Messages:
    26
    Likes Received:
    0
    Joined:
    Feb 26, 2017
    the first mistake was one that a lot of open public. The second error was in the wrong bundles of doors Manager. the third mistake was the syntax of writing code. wrong brackets and the arguments.
     
  15. Saf

    Saf New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Mar 8, 2017
    Hi ShotGun21 , can you upload the game mode with your update ..

    Thank's in Advance ;-)
     
  16. MittelDrache38

    MittelDrache38 New Member

    Messages:
    1
    Likes Received:
    0
    Joined:
    Apr 17, 2017
  17. Coro

    Coro Member

    Messages:
    12
    Likes Received:
    0
    Joined:
    Apr 3, 2017
    There is a great desynchronization in this GAMEMODE, When I open the map, the FPS goes down from 60 to 9.
     
    Last edited: Apr 19, 2017
  18. Kasztura

    Kasztura New Member

    Messages:
    1
    Likes Received:
    0
    Joined:
    Apr 23, 2017
    I'm work on this since 2 hours and now i get this error, any sugestions ?

    Code:
    =======================================================================
    = GRAND THEFT AUTO NETWORK v0.1.367.419
    =======================================================================
    = Server Name: Simple GTA Network Server
    = Server Port: 4499
    = Server FQDN:
    =
    = Player Limit: 50
    = Log Level: 0 (2: ERROR, 3: DEBUG, 4: VERBOSE)
    =======================================================================
    [16:03:25] Starting...
    [16:03:25] Loading resources...
    [16:03:25] Starting ShittyRPG-master
    [16:03:25] Error/warning while compiling script!
    [16:03:25] Error (CS1519) at 152: Unexpected symbol `=' in class, struct, or interface member declaration
    [16:03:25] Error (CS1519) at 155: Unexpected symbol `(' in class, struct, or interface member declaration
    [16:03:25] Error (CS1519) at 155: Unexpected symbol `)' in class, struct, or interface member declaration
    [16:03:25] Error (CS1519) at 156: Unexpected symbol `(' in class, struct, or interface member declaration
    [16:03:25] Error (CS1519) at 156: Unexpected symbol `)' in class, struct, or interface member declaration
    [16:03:25] Error (CS1519) at 157: Unexpected symbol `(' in class, struct, or interface member declaration
    [16:03:25] Error (CS1519) at 159: Unexpected symbol `(' in class, struct, or interface member declaration
    [16:03:25] Error (CS1519) at 159: Unexpected symbol `,' in class, struct, or interface member declaration
    [16:03:25] Error (CS1519) at 159: Unexpected symbol `)' in class, struct, or interface member declaration
    [16:03:25] Error (CS1519) at 161: Unexpected symbol `;' in class, struct, or interface member declaration
    [16:03:25] Error (CS1525) at 164: Unexpected symbol `void'
    [16:03:25] ERROR STARTING RESOURCE ShittyRPG-master
    [16:03:25] System.ArgumentNullException: Value cannot be null.
    Parameter name: source
      at System.Linq.Enumerable.Select[TSource,TResult] (System.Collections.Generic.IEnumerable`1[T] source, System.Func`2[T,TResult] selector) [0x00010] in <2392cff65f724abaaed9de072f62bc4a>:0
      at GTANetworkServer.GameServer.StartResource (System.String resourceName, System.String father) [0x00b43] in <8ac7be119df140b79de84a21331c2fa9>:0
    [16:03:25] Started! Waiting for connections.
    
     
  19. Coro

    Coro Member

    Messages:
    12
    Likes Received:
    0
    Joined:
    Apr 3, 2017
    Apparently you have edited something and it is telling you in which lines you have the error. From line 152 to line 164.

    If you can pass a capture of the file that you have modified, maybe I can help you.
     
  20. Rosellonsito

    Rosellonsito Member

    Messages:
    11
    Likes Received:
    0
    Joined:
    Apr 24, 2017
    I can't login, it say-> ERROR: No account found with your name. And When I go to register another time it say-> ERROR: An account linked to this Social Clud handle already exists!
     
    Last edited: Apr 25, 2017

Share This Page