1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. GTA Network forum is now in archive mode.

Closed Server requirements?

Discussion in 'Solved & Closed' started by Bomlife, Dec 20, 2016.

Thread Status:
Not open for further replies.
  1. Bomlife

    Bomlife New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Dec 6, 2016
    What are the system requirements for the server? Which OS do you recommend?
     
  2. Duzoh

    Duzoh Member

    Messages:
    25
    Likes Received:
    12
    Joined:
    Sep 22, 2016
    IDK the system requeriments but i recommend you Linux for a server
     
  3. unSatisfied

    unSatisfied Member

    Messages:
    22
    Likes Received:
    4
    Joined:
    Dec 18, 2016
    Let me know how running .NET goes on Linux without .NET Core and/or Mono Yes~~
     
  4. Gachl

    Gachl New Member

    Messages:
    2
    Likes Received:
    1
    Joined:
    Dec 23, 2016
    It works okay using mono, all I had to do was update to mono 4.6.2 and link the System.IO.dll and System.Linq.dll in the folder where the GTANetworkServer.exe is.
    The server requires those two libraries for compiling C# scripts and apparently it can't find them on Linux, except when you put them right next to it.
     
  5. Decadente

    Decadente Member

    Messages:
    6
    Likes Received:
    3
    Joined:
    Dec 5, 2016
    What I had to do for my server to work was placing them inside /usr/lib/mono/4.5-api/ . Neither in server root folder or serverrootfolder/bin worked. In my case a freshly installed Ubuntu Server 16.04 LXC container. Just some insight.
     
    Brad likes this.
  6. Kruzzel

    Kruzzel Active Member

    Messages:
    61
    Likes Received:
    2
    Joined:
    Dec 12, 2016
    I don't understand why GTA:N doesn't load. It connects into the game but it says I'm disconnected on Social Club and starts GTAV Singleplayer...

    PS: Also tried to use that .dll
     
  7. Gomitung

    Gomitung Member

    Messages:
    44
    Likes Received:
    36
    Joined:
    Aug 2, 2016
    After doing some tests, I found out the Mono uses more RAM(around 100MB) than Windows. When testing I easily reached 300MB with Linux so RAM is a needed thing.
     
Thread Status:
Not open for further replies.

Share This Page